User Tools

Site Tools


staticgenerators

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
staticgenerators [2017/05/12 09:13]
carl
staticgenerators [2017/05/12 09:29] (current)
carl
Line 21: Line 21:
  
 ====== Harp ====== ====== Harp ======
 +===== Installation =====
 <code>sudo aptitude install npm <code>sudo aptitude install npm
 sudo npm install -g harp</code> sudo npm install -g harp</code>
Line 37: Line 38:
 > Harp v0.20.0 supports Node v5.x, and simultaneously removes support for Node v0.10.x. > Harp v0.20.0 supports Node v5.x, and simultaneously removes support for Node v0.10.x.
  
-Il faut donc installer une version plus récente de node.js: https://nodejs.org/en/download/+Il faut donc installer une version plus récente de node.js: https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-based-linux-distributions
 <code>sudo aptitude install curl <code>sudo aptitude install curl
 curl -sL https://deb.nodesource.com/setup_6.x | sudo -E bash - curl -sL https://deb.nodesource.com/setup_6.x | sudo -E bash -
 sudo aptitude install nodejs sudo aptitude install nodejs
 sudo aptitude install nodejs</code> sudo aptitude install nodejs</code>
-La première fois qu'on fait install nodejs, il désinstalle npm et nodejs (ancienne version), la 2e fois il installe nodejs:+La première fois qu'on fait install nodejs, il désinstalle npm et nodejs (ancienne version), la 2e fois il installe nodejs :
 <code>nodejs --version <code>nodejs --version
-v6.10.3</code>+v6.10.3 
 +npm --version 
 +3.10.10 
 +sudo npm install -g harp</code>
  
 +Il y a des avertissements:
 +<code>npm WARN deprecated jade@1.11.0: Jade has been renamed to pug, please install the latest version of pug instead of jade
 +npm WARN deprecated transformers@2.1.0: Deprecated, use jstransformer
 +/usr/bin/harp -> /usr/lib/node_modules/harp/bin/harp</code>
  
 +Mais harp est installé:
 +<code>harp --version
 +0.23.0</code>
staticgenerators.1494573239.txt.gz · Last modified: 2017/05/12 09:13 by carl