User Tools

Site Tools


ubuntulinux

http://www.ubuntu.com/

Elle est basée sur sid (Debian unstable) et GNOME.

La distribution tient sur un seul CD, on peut accéder à tous les packages par internet (cf. http://packages.ubuntu.com/ ).

Voir aussi FAQs: Why and Whither for Ubuntu?

Versions

Ubuntu 4.10 Warthy Warthog

Je l'ai installée sur le MedionDesktop sans problème. Un petit désagrément: ayant choisi la langue anglaise, il ne m'a pas demandé de layout pour mon clavier.

Seule surprise, il n'y a pas de mot de passe root, on doit utiliser sudo. Pour pouvoir s'identifier en tant que root, il faut faire:

sudo -s

Je comptais l'installer en dual boot sur ~l'iMac G5 de mes parents en dualboot: PPC, mais cela ne les intéresse pas. Attendons qu'il soit obsolète avec MacOS

Les softs utilisés:

Articles:

Repositories non-officiels

## some updated warty packages from Markus Hubig
  deb http://www.stud.uni-karlsruhe.de/~ut8g/ubuntu warty-updates main universe
  deb-src http://www.stud.uni-karlsruhe.de/~ut8g/ubuntu warty-updates main universe

Problèmes

  • comment installer dvd::rip avec warty warthog? (problème de dépendances non satisfaites)

Améliorations

Ce sont évidemment surtout des améliorations des logiciels inclus dans Ubuntu.

Ubuntu 5.04 Hoary Hedgehog

Live CD

Pour le mitac, j'ai booté avec comme paramètres:

boot: live vga=771

Problème:

There was a problem reading data from the CDROM. Please make sure it is in the drive. If retrying does not work, your should check the integrity of your CDROM.
Failed to copy file from CDROM. Retry?

Quand je vérifie le disque (Check the CD-ROM(s) integrity), j'ai l'erreur suivante:

The ./pool/main/l/linux-source-2.6.10/acpi-modules-2.6.10-4-386-di_2.6.10-25.2_i386.udeb file failed the MD5 checksum verification. Your CD-ROM or this file may have been corrupted.

Le MD5 checksum de l'iso est ok:

Quand je monte l'iso et que je fais:

cd /media/cdrom1/
md5sum -cv md5sum.txt

J'ai une erreur:

./casper/filesystem.cloop
error processing ./casper/filesystem.cloop: failed in buffer_read(fd): mdfile: Input/output error
FAILED

J'ai donc gravé une 2e image iso, mais c'est pareil. C'était le lecteur de CD-ROM qui foirait…

Hoary Install

cf. HoaryHedgehog

Je suis assez content dans l'ensemble.

Ubuntu 5.10 Breezy Badger

Breezy Install

cf. BreezyBadger pour la version i386 et Linux pour la version PPC.

Ca tourne bien aussi.

Beagle

J'ai bien apprécié de pouvoir chercher dans mes emails aussi facilement qu'avec Spotlight sous MacOs X.

Donc, j'installe Beagle, l'équivalent sous GNOME, d'après les instructions.

  • modifier /etc/apt/sources.list pour que universe soit actif
  • sudo apt-get install mono mono-jit mono-utils mono-mcs mono-assemblies-arch mono-assemblies-base mono-common libmono0 mono-devel
  • mais il y a un problème:
Package mono-assemblies-arch is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source

Article introduisant Beagle: Beagle - a desktop search tool that works like an Internet search engine, Linux Magazine sep 2005

CUPS

Ubuntu 6.10 Edgy Eft

  • 27/10/06: installation (à la place de Debian Etch (encore testing) sur le MacBook: EdgyEft: c'est pas encore au point, je vais devoir chipoter
  • 28/10/06: upgrade de Breezy vers Edgy sur le MacMini: Linux: ça s'est bien déroulé, il a fallu juste chipoter pour le son.

Impressions: j'aime bien le thème GNOME Human et Tomboy à l'air sympa (bien que je n'en aie pas besoin puisque j'ai ce WikiWikiWeb :)

Ubuntu 7.4 Feisty Fawn

  • 20/04/07: mise à jour d' excalibur: tout s'est bien passé.
  • avril 2007: installation sur le MacBook: ça marche.

Problèmes:

  • multi-session X: ça ne se passe pas bien pour passer d'une console à l'autre
    • solution pour MedionDesktop: désactiver Compiz: System > Preferences > Desktop Effects > tout désélectionner
    • crashes de Evolution lorsque j'allais dans les préférences (c'est fini, aucune idée pourquoi)
    • problèmes début mai avec sound-juicer (ne démarrait plus), désinstallé-réinstallé par la suite: OK
    • audacity: pas moyen d'entendre le son dans les hauts-parleurs (sélection I/O sound: pas ce qu'il faut comme sorties possibles)

Ubuntun 7.10 Gutsy Gibbon

Tout va bien, j'ai réinstallé (mais pas dû reconfigurer) BblWebBanking.

Pour les mp3, DVDs, etc., il faut chipoter.

MP3:

  • démarrer totem (Applications > Sound & Video > Movie Player)
  • ouvrir un fichier mp3
  • installer les 2 plugins proposés

Et ça marche aussi dans Rhythmbox.

DVDs:

  • ajouter dans /etc/apt/sources.list:
deb http://packages.medibuntu.org/ gutsy free non-free
  • mettre à jour la liste de paquets:
sudo aptitude update
  • installer les paquets
sudo aptitude install libdvdcss2
sudo aptitude install w32codecs

Toujours pas moyen de jouer certaines DVDs ou contenu en ligne, donc on passe à vlc:

sudo aptitude install vlc mozilla-plugin-vlc

Les plugins Totem sont prioritaires par rapport à ceux de vlc, on les enlève:

sudo rm /usr/lib/firefox/plugins/libtotem-*

Voici ce qu'il y avait:

lrwxrwxrwx 1 root root   36 2007-10-19 20:04 libtotem-basic-plugin.so -> ../../totem/libtotem-basic-plugin.so
lrwxrwxrwx 1 root root   37 2007-10-19 20:04 libtotem-basic-plugin.xpt -> ../../totem/libtotem-basic-plugin.xpt
lrwxrwxrwx 1 root root   34 2007-10-19 20:04 libtotem-gmp-plugin.so -> ../../totem/libtotem-gmp-plugin.so
lrwxrwxrwx 1 root root   35 2007-10-19 20:04 libtotem-gmp-plugin.xpt -> ../../totem/libtotem-gmp-plugin.xpt
lrwxrwxrwx 1 root root   36 2007-10-19 20:04 libtotem-mully-plugin.so -> ../../totem/libtotem-mully-plugin.so
lrwxrwxrwx 1 root root   37 2007-10-19 20:04 libtotem-mully-plugin.xpt -> ../../totem/libtotem-mully-plugin.xpt

lrwxrwxrwx 1 root root   42 2007-10-19 20:04 libtotem-narrowspace-plugin.so -> ../../totem/libtotem-narrowspace-plugin.so
lrwxrwxrwx 1 root root   43 2007-10-19 20:04 libtotem-narrowspace-plugin.xpt -> ../../totem/libtotem-narrowspace-plugin.xpt

Il y a un bug dans Pidgin: http://developer.pidgin.im/ticket/3552

Configuration glslideshow

Pour déterminer le répertoire d'où prendre les photos:

 echo "imageDirectory: /home/user/Pictures" > ~/.xscreensaver

Pour configurer le temps entre les photos: Dans /usr/share/applications/screensavers/glslideshow.desktop, remplacer la ligne

Exec=glslideshow -root

par:

Exec=glslideshow -root -duration 15 -pan 15 -fade 5

où:

  • duration = le temps que reste l'image
  • pan = le “panning” (effet panorama: la caméra bouge sur un axe horizontal)
  • fade = le temps pour qu'on passe d'une image à l'autre

source

Ubuntu 8.10 Intepid Ibex

Released 30 oct 2008, je l'ai installé nov 1 sur le MacBook: UbuntuIntrepidIbex

Pas de problème particulier so far.

Ubuntu 9.04 Jaunty Jackalope

Installation de la version beta sur MacMiniIntel.

Comment désactiver le compte “guest” dans l'applet fast-user-switch ?

sudo aptitude remove gdm-guest-session

Ubuntu 9.10 Karmic Koala

Upgrade sans problème sur le MacMiniIntel (desktop), from scratch sur le MacBook (comme 3e OS, j'ai réduit la partition de la version précédente) et upgrade sur l'AsusEEE1000HE.

Tout tourne très bien, j'ai juste du rajouter un symlink pour BblWebBanking sur le desktop.

Je dois encore paramétrer le clic droit sur le MacBook et résoudre la connexion à fb avec Empathy sur le desktop.

Ubuntu 10.4 Lucid Lynx

Comment avoir l'environnement en français pour certains utilisateurs?

sudo aptitude install language-pack-fr language-pack-gnome-fr openoffice.orgl10n-fr
LANG="fr_BE.UTF-8"

Et ensuite, il faut changer de langue et de “texte” dans Menu > System > Administration > Language support

Installer Virtualbox

sudo add-apt-repository "deb http://download.virtualbox.org/virtualbox/debian lucid non-free"
wget -q http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc -O- | sudo apt-key add -
sudo aptitude update
sudo aptitude install virtualbox-3.2

( source)

Vu que Lucid est un LTS, je suis resté avec en attendant le suivant (12.04, Precise Pangolin) sur la plupart de mes machines…

ubuntulinux.txt · Last modified: 2013/01/30 17:51 (external edit)