User Tools

Site Tools


quickcam

Table of Contents

gnulinux > hardware

Logitech QuickCam Pro 4000, une webcam basique du début du siècle…

Pour la faire fonctionner avec GnomeMeeting, il suffit d'avoir un noyau récent (2.4.22 pour ma part) et d'ajouter un module.

On pouvait le trouver sur Linux drivers for Philips USB webcams: http://www.smcc.demon.nl/webcam/pwcx-8.2.2.tar.gz

Le site a été fermé :(

J'ai mis à disposition les 2 archives compressées contenant les drivers. La dernière version du driver pwc est 9.0.2, mais je n'ai pas réussi à mettre la main dessus :(

Bonne nouvelle, quelqu'un va prendre la relève: http://kerneltrap.org/node/view/3747

Noyau 2.4

Je l'avais fais à l'époque avec la version 8.2.2.

Il faut le décompresser, et ensuite copier le module dans le répertoire /usr/source/linux/modules/drivers/usb/ et le renommer en pwcx.o

Ensuite, il faut refaire les dépendences des modules du noyau, puis charger le module pwcx en mémoire (NB: ici avec ancienne version 8.2.2) :

tar xzf pwcx-8.2.2.tar.gz
cp usb-pwcx-8.2.2/x86/gcc-3.2/pwcx-2.4.20.o /lib/modules/2.4.22-test/kernel/drivers/usb/pwcx.o
cd /usr/src/linux-2.4.22/
depmod -a
insmod -f pwcx

Noyau 2.6

Installation avec le noyau 2.6.7 (cf. Sarge).

Décompresser l'archive et suivre les instructions du README.

tar xzf pwcx-9.0.tar.gz
cd /usr/src/linux
patch -p1 -s < /home/carl/download/pwcx-9.0/patch-2.6.4
cp /home/carl/download/pwcx-9.0/x86/libpwcx.a drivers/usb/media/libpwcx.a 
cp /home/carl/download/pwcx-9.0/pwcx/*.[ch] drivers/usb/media
make menuconfig

Problème:

>> Unable to find the Ncurses libraries.
>>
>> You must install ncurses-devel in order
>> to use 'make menuconfig'

Solution:

aptitude install libncurses5-dev

On continue:

 make menuconfig

Device Drivers –> USB support –> PWCX decompressor module Mettre à 'M', puis sortir en sauvant la configuration.

make modules modules_install

Ensuite, on peut tester avec le petit logiciel fourni.

Ça marche pas…

A noter que le développement à l'air d'avoir continué sur http://cercle-daejeon.homelinux.org/linux/ et plus récemment sur http://www.saillard.org/pwc/ ( annonce)

J'ai suivi les instructions pour avoir le module pwc et ça marche.

Liens

quickcam.txt · Last modified: 2017/12/03 15:15 by carl